Rabu, 24 Oktober 2012

Lab 52. OSPF - Stub Area


Objective :
  • Stub artinya ujung, merupakan router atau area yang paling ujung atau sisi paling akhir dan tidak memiliki cabang lain serta tidak memiliki jalan lain untuk menuju jaringan dengan segmen lain.
  • Semua external router LSA type 4 dan 5 (network dari routing lain yang diredistribute ke dalam OSPF) tidak dimasukkan dalam routing tabel
  • Sebagai gantinya digunakanlah default route untuk menuju ke network-network tersebut
  • Hal ini akan mengurangi kinerja CPU dan memori router, mengurangi jumlah routing tabel
  • Dikonfigurasikan di semua router yang ada dalam stub area
Topology dan konfigurasinya sebagai berikut

Konfigurasi R1
  
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 network 12.12.12.1 0.0.0.0 area0
 network 1.1.1.1 0.0.0.0 area 0
Konfigurasi R2
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 2
 router-id 2.2.2.2
 network 12.12.12.2 0.0.0.0 area0
 network 23.23.23.2 0.0.0.0 area1
 network 2.2.2.2 0.0.0.0 area1
Konfigurasi R3
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 3
 router-id 3.3.3.3
 network 23.23.23.3 0.0.0.0 area1
 network 3.3.3.3 0.0.0.0 area1

Create interface loopback baru
Advertise kedalam EIGRP untuk interface loopback 4,5,6, dan 7
Selebihnya advertise kedalam OSPF area 100 dan redistribute network EIGRP kedalam OSPF
Cek routing tabel pada Router R2 dan Router R3

Seperti yang terlihat dalam routing tabel pada R3. Untuk IP 100.100.100.1-3 merupakan Inter Area ( Area 0, Area 1 dan  area 100). Sedangkan untuk IP 100.100.100.4-7 merupakan External Area yaitu yang berasal dari network EIGRP.

Sekarang konfigurasikan untuk stub area nya.
Cek kembali routing table pada Router R3
Seperti yang terlihat untuk network diluar OSPF (network EIGRP) tidak lagi terdapat dalam routing tabelnya, sebagai penggantinya menggunakan default route untuk menuju ke network-network tersebut sehingga masih dapat di ping dari Router R3.

Cek juga pada OSPF databasenya.
Pada OSPF databasenya yang ditampilkan hanya LSA Type 1 dan LSA Type 3 saja.


Tidak ada komentar:

Poskan Komentar