Rabu, 24 Oktober 2012

Lab 53. OSPF - Totally Stub Area


Objective :
  •  Lebih sadis dari Stub Area, karena kini benar - benar totally stub
  • Bukan hanya External Route saja, bahkan Internal Route dari OSPF area lain juga tidak dimasukkan dalam routing tabel
  • Konfigurasi hanya dilakukan pada router ABR nya saja, tidak di semua router dalam stub area
  • Router R2 merupakan ABR ( Area Border Router ) yang menghubungkan Area 0 dan Area 1.
Topology dan konfigurasinya sebagai berikut
Konfigurasi R1
  
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
 ip address 100.100.100.2 255.255.255.255
!
interface Loopback3
 ip address 100.100.100.3 255.255.255.255
!
interface Loopback4
 ip address 100.100.100.4 255.255.255.255
!
interface Loopback5
 ip address 100.100.100.5 255.255.255.255
!
interface Loopback6
 ip address 100.100.100.6 255.255.255.255
!
interface Loopback7
 ip address 100.100.100.7 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 100.100.100.4 0.0.0.0
 network 100.100.100.5 0.0.0.0
 network 100.100.100.6 0.0.0.0
 network 100.100.100.7 0.0.0.0
 auto-summary
!
router ospf 1
 router-id 1.1.1.1
 redistribute eigrp 1 subnets
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 100
 network 100.100.100.2 0.0.0.0 area 100
 network 100.100.100.3 0.0.0.0 area 100
!

Konfigurasi R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 2
 router-id 2.2.2.2
 network 12.12.12.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 1
 network 2.2.2.2 0.0.0.0 area 1
 area 1 stub

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 3
 router-id 3.3.3.3
 network 23.23.23.3 0.0.0.0 area 1
 network 3.3.3.3 0.0.0.0 area 1
 area 1 stub

Cek routing table pada Router R3
Seperti yang terlihat untuk network diluar OSPF (network EIGRP) tidak terdapat dalam routing tabelnya, sebagai penggantinya menggunakan default route untuk menuju ke network-network tersebut sehingga masih dapat di ping dari Router R3.
Cek juga pada OSPF databasenya.
Pada OSPF databasenya yang ditampilkan hanya LSA Type 1 dan LSA Type 3 saja.
Sekarang hapus dulu untuk perintah area 1 stub diganti dengan perintah area 1 stub no-summary pada Router R2 saja.
Cek kembali routing tabel Router R3
Kalau sebelumnya routing berikut masih ada pada OSPF Stub Area
Maka pada OSPF Totally Stub Area tidak lagi terdapat dalam routing tabelnya

Cek OSPF database nya
Dalam OSPF database, semua LSA Type 3 kecual default route dihapus.
 Jika sebelumnya link berikut masih ada, sekarang sudah tidak lagi terdapat dalam OSPF database nya.

Tidak ada komentar:

Poskan Komentar