Rabu, 24 Oktober 2012

Lab 54. OSPF - Not So Stubby Area


Objective :
  • Kalau pada stub dan totally stub area, maka External Route benar-benar tidak diterima ataupun dikirimkan, bila diinginkan pada area stub masih bisa mengirim External Route maka solusinya dengan menggunakan NSSA (Not So Stubby Area).
  • Namun External Route ini tidak sebagai LSA Type 5, melainkan dalam bentuk LSA Type 7, karena memang LSA Type 3,4,5 benar-benar dibatasi pada stub area, jadi alternatifnya menggunakan LSA Type 7.
  • Dan jika diinginkan Internal Route OSPF dari area lain masih bisa diterima, maka solusinya juga menggunakan NSSA.
  • Dikonfigurasikan pada semua router pada area stub
Topology dan konfigurasi
 Konfigurasi R1
  
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
 ip address 100.100.100.2 255.255.255.255
!
interface Loopback3
 ip address 100.100.100.3 255.255.255.255
!
interface Loopback4
 ip address 100.100.100.4 255.255.255.255
!
interface Loopback5
 ip address 100.100.100.5 255.255.255.255
!
interface Loopback6
 ip address 100.100.100.6 255.255.255.255
!
interface Loopback7
 ip address 100.100.100.7 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 1
 network 100.100.100.4 0.0.0.0
 network 100.100.100.5 0.0.0.0
 network 100.100.100.6 0.0.0.0
 network 100.100.100.7 0.0.0.0
 auto-summary
!
router ospf 1
 router-id 1.1.1.1
 redistribute eigrp 1 subnets
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 100
 network 100.100.100.2 0.0.0.0 area 100
 network 100.100.100.3 0.0.0.0 area 100
!
Konfigurasi R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 2
 router-id 2.2.2.2
 network 12.12.12.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 1
 network 2.2.2.2 0.0.0.0 area 1
 area 1 stub no-summary

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 3
 router-id 3.3.3.3
 network 23.23.23.3 0.0.0.0 area 1
 network 3.3.3.3 0.0.0.0 area 1
 area 1 stub

Tambahkan dulu Routing External RIP yang diredistribute ke OSPF di Router R3 area stub
 Selanjutnya konfigurasikan NSSA
Cek routing tabelnya
Dan External Route RIP dari R3 bisa diterima di Router R1
Ok sekarang Internal Area dari OSPF Area 100 bisa diterima dengan baik di stub Router R3.
Namun belum terdapat default route nya, sehingga R3 belum bisa ping ke IP 100.100.100.4 - 100.100.100.7 yang merupakan network EIGRP di R1 yang diredistribute ke OSPF.
Maka perlu menambahkan konfigurasi berikut pada router ABR nya saja (dalam topology ini Router R2)
Selanjutnya cek lagi pada routing tabel Router R3
Default route (0.0.0.0/0) sudah muncul sekarang lakukan tes ping lagi
Kalau diinginkan internal route OSPF area lain tidak ditampilkan dalam database nya, namun masih bisa mengirimkan external route RIP nya, maka tambahkan no-summary pada router ABR R2.
Maka pada Router R3 sudah tidak lagi terdapat routing inter area, digantikan dengan default route saja.
Lakukan test ping
Dan pastikan juga route external RIP dari R3 masih bisa diterima di Router R1
Lakukan test ping


Tidak ada komentar:

Poskan Komentar