Objective : Mempelajari konfigurasi sham-link pada Jaringan MPLS VPN yang menggunakan OSPF sebagai koneksi PE dan CE.
Topologi Lab
Kondisi awal, interface serial antara Router CE1_BRI dan Router CE2_BRI dalam kondisi shutdown, sehingga dari Router CE1_BRI untuk menuju ke Router CE2_BRI akan menggunakan link MPLS nya. Selanjutnya ketika interface serial nya telah aktif kembali maka Router CE1_BRI akan langsung menuju Router CE2_BRI tanpa melalui MPLS nya terlebih dahulu. Hal ini disebabkan oleh :
- Directly Connected (AD = 0) memiliki AD yang lebih rendah dibandingkan dengan OSPF (AD = 100)
Konfigurasi PE1
!
ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
ip vrf bca.kiri
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kiri
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
description ###Link to P Router###
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
description ###Link to BCA###
ip vrf forwarding bca.kiri
ip address 10.10.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
description ###Link to BRI###
ip vrf forwarding bri.kiri
ip address 10.10.10.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
Konfigurasi P Router
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
description ###Link to PE1 Router###
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
description ###Link to PE2 Router###
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
network 23.23.23.2 0.0.0.0 area 0
!
Konfigurasi PE2
!
ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
ip vrf bca.kanan
rd 65000:2
route-target export 65000:2
route-target import 65000:2
!
ip vrf bri.kanan
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
description ###Link to P Router###
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
description ###Link to BRI###
ip vrf forwarding bri.kanan
ip address 10.10.10.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
description ###Link to BCA###
ip vrf forwarding bca.kanan
ip address 10.10.10.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 23.23.23.3 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
Konfigurasi CE1_BRI
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
description ###Link to MPLS###
ip address 10.10.10.2 255.255.255.252
duplex auto
speed auto
interface FastEthernet1/0
description ###Link to MPLS###
ip address 10.10.10.2 255.255.255.252
duplex auto
speed auto
!
interface Serial2/0
ip address 45.45.45.4 255.255.255.0
serial restart-delay 0
interface Serial2/0
ip address 45.45.45.4 255.255.255.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
Konfigurasi CE2_BRI
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet1/0
description ###Link to MPLS###
ip address 10.10.10.6 255.255.255.252
duplex auto
speed auto
!
interface Serial2/0
ip address 45.45.45.5 255.255.255.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet1/0
description ###Link to MPLS###
ip address 10.10.10.6 255.255.255.252
duplex auto
speed auto
!
interface Serial2/0
ip address 45.45.45.5 255.255.255.0
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
Selanjutnya cek kembali rute yang dipilih dari Router CE1_BRI ke RouterCE2_BRI
Ternyata dalam hal ini Router CE1_BRI ke CE2_BRI akan lebih memilih jalur backdoornya yaitu melalui interface serialnya.
Untuk sham link membutuhkan ip loopback /32 terkait dengan sham-link source dan destination nya.
Untuk mengatasi hal tersebut maka konfigurasikan seperti berikut.
Router PE1
Tunggu beberapa saat atau bisa clear ip ospf process dulu. Periksa kembali route tabel nya, pastikan dapat di ping dan coba di traceroute.
Tidak ada komentar:
Posting Komentar