Objective :
- Weight merupakan atribut yang diciptakan khusus untuk penggunaan di router keluaran vendor Cisco. Atribut ini merupakan atribut dengan priority tertinggi dan sering digunakan dalam proses path selection. Atribut ini bersifat lokal hanya untuk digunakan pada router tersebut dan tidak diteruskan ke router lain karena belum tentu router lain yang bukan bermerk Cisco dapat mengenalinya. Fungsi dari atribut ini adalah untuk memilih salah satu jalan yang diprioritaskan dalam sebuah router.
Topologi Lab
Konfigurasi R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
neighbor 5.5.5.5 remote-as 12
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
neighbor 5.5.5.5 remote-as 12
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
Konfigurasi R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
network 25.25.25.2 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 12
neighbor 5.5.5.5 update-source Loopback0
neighbor 5.5.5.5 next-hop-self
neighbor 5.5.5.5 route-map WEIGHT in
neighbor 23.23.23.3 remote-as 34
neighbor 23.23.23.3 next-hop-self
no auto-summary
!
route-map WEIGHT permit 10
set weight 100
!
Konfigurasi R3
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
network 25.25.25.2 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 12
neighbor 5.5.5.5 update-source Loopback0
neighbor 5.5.5.5 next-hop-self
neighbor 5.5.5.5 route-map WEIGHT in
neighbor 23.23.23.3 remote-as 34
neighbor 23.23.23.3 next-hop-self
no auto-summary
!
route-map WEIGHT permit 10
set weight 100
!
Konfigurasi R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback33
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 34.34.34.3 0.0.0.0 area 0
network 36.36.36.3 0.0.0.0 area 0
!
router bgp 34
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 4.4.4.4 remote-as 34
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
neighbor 6.6.6.6 remote-as 34
neighbor 6.6.6.6 update-source Loopback0
neighbor 6.6.6.6 next-hop-self
neighbor 23.23.23.2 remote-as 12
neighbor 23.23.23.2 next-hop-self
no auto-summary
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback33
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.3 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 34.34.34.3 0.0.0.0 area 0
network 36.36.36.3 0.0.0.0 area 0
!
router bgp 34
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 4.4.4.4 remote-as 34
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
neighbor 6.6.6.6 remote-as 34
neighbor 6.6.6.6 update-source Loopback0
neighbor 6.6.6.6 next-hop-self
neighbor 23.23.23.2 remote-as 12
neighbor 23.23.23.2 next-hop-self
no auto-summary
!
Konfigurasi R4
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback44
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 34.34.34.4 0.0.0.0 area 0
!
router bgp 34
no synchronization
bgp log-neighbor-changes
network 44.44.44.44 mask 255.255.255.255
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 update-source Loopback0
neighbor 6.6.6.6 remote-as 34
neighbor 6.6.6.6 update-source Loopback0
no auto-summary
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback44
ip address 44.44.44.44 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 34.34.34.4 0.0.0.0 area 0
!
router bgp 34
no synchronization
bgp log-neighbor-changes
network 44.44.44.44 mask 255.255.255.255
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 update-source Loopback0
neighbor 6.6.6.6 remote-as 34
neighbor 6.6.6.6 update-source Loopback0
no auto-summary
!
Konfigurasi R5
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback55
ip address 55.55.55.55 255.255.255.255
!
interface FastEthernet0/0
ip address 56.56.56.5 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.5 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 25.25.25.5 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 55.55.55.55 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 56.56.56.6 remote-as 34
neighbor 56.56.56.6 next-hop-self
no auto-summary
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Loopback55
ip address 55.55.55.55 255.255.255.255
!
interface FastEthernet0/0
ip address 56.56.56.5 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 25.25.25.5 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 25.25.25.5 0.0.0.0 area 0
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 55.55.55.55 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 56.56.56.6 remote-as 34
neighbor 56.56.56.6 next-hop-self
no auto-summary
!
Konfigurasi R6
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Loopback66
ip address 66.66.66.66 255.255.255.255
!
interface FastEthernet0/0
ip address 56.56.56.6 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.6 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 0
network 36.36.36.6 0.0.0.0 area 0
!
router bgp 34
no synchronization
bgp log-neighbor-changes
network 66.66.66.66 mask 255.255.255.255
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 4.4.4.4 remote-as 34
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
neighbor 56.56.56.5 remote-as 12
neighbor 56.56.56.5 next-hop-self
no auto-summary
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Loopback66
ip address 66.66.66.66 255.255.255.255
!
interface FastEthernet0/0
ip address 56.56.56.6 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 36.36.36.6 255.255.255.0
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 0
network 36.36.36.6 0.0.0.0 area 0
!
router bgp 34
no synchronization
bgp log-neighbor-changes
network 66.66.66.66 mask 255.255.255.255
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 4.4.4.4 remote-as 34
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
neighbor 56.56.56.5 remote-as 12
neighbor 56.56.56.5 next-hop-self
no auto-summary
!
Verifikasi Lab
Traceroute dari Router R1 menuju Router R4
Secara default BGP akan memilih rute R1-R2-R3-R4. Agar Rute nya dialihkan menjadi R1-R2-R5-R6-R3-R4 maka tambahkan nilai weight nya. Nilai weight yang terbesar yang akan terpilih sebagai rute terbaiknya.
Trace lagi
Tidak ada komentar:
Posting Komentar