Objective :
- Mempelajari salah satu atribut pada BGP yakni community
- Attribute Community terbagi menjadi 4 yakni no-export, no-advertise, internet dan local-as
Topologi Lab
Konfigurasi R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
no auto-summary
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 123
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 123
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
Konfigurasi R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 24.24.24.2 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 123
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 route-reflector-client
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 123
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 route-reflector-client
neighbor 3.3.3.3 next-hop-self
neighbor 24.24.24.4 remote-as 4
no auto-summary
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 24.24.24.2 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 123
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 route-reflector-client
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 123
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 route-reflector-client
neighbor 3.3.3.3 next-hop-self
neighbor 24.24.24.4 remote-as 4
no auto-summary
!
Konfigurasi R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback33
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback33
ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 123
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
!
router bgp 123
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 123
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
Konfigurasi R4
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback44
ip address 44.44.44.44 255.255.255.255
!
interface Serial1/0
ip address 24.24.24.4 255.255.255.0
serial restart-delay 0
clock rate 2016000
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback44
ip address 44.44.44.44 255.255.255.255
!
interface Serial1/0
ip address 24.24.24.4 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 4
no synchronization
bgp log-neighbor-changes
network 44.44.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 123
no auto-summary
!
router bgp 4
no synchronization
bgp log-neighbor-changes
network 44.44.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 123
no auto-summary
!
Cek BGP route di Router R1 dan R4
Set community "no-export" di Router R1 (no-export tidak diadvertise ke eBGP)
Cek BGP route di Router R4 pastikan network 11.11.11.11/32 sudah tidak ada
Set community "no-advertise" di Router R3 (no-advertise tidak akan diadvertise ke iBGP/eBGP)
Cek BGP route di Router R1 dan Router R4 dan pastikan network 33.33.33.33/32 sudah tidak ada.
Set community "Local-AS" di Router R1 (diadvertise hanya di confederation iBGP saja). Artinya konfigurasi iBGP (R1,R2,R3) harus dirubah dari Route Reflector menjadi Confederation
Cek BGP route di Router R3 pastikan network 11.11.11.11/32 sudah tidak ada dikarenakan sudah berbeda AS nya.
Tidak ada komentar:
Posting Komentar