Objective :
- mempelajari Next-Hop yang ada pada BGP
- Mempelajari mengapa Next-Hop-Self perlu dikonfigurasikan
- Mengetahui bahwa route yang diadvertise pada BGP dan tampil dalam perintah show ip bgp tidak semuanya akan tampil dalam routing tabel (show ip route) dikarenakan IP next hop nya unreachable.
Topologi Lab
Konfigurasi R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
ip address 21.21.21.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
network 21.0.0.0
no auto-summary
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
Konfigurasi R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface Serial1/0
ip address 32.32.32.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.2 255.255.255.0
serial restart-delay 0
!
interface FastEthernet2/0
ip address 21.21.21.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 21.0.0.0
network 23.0.0.0
network 32.0.0.0
no auto-summary
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 255
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
Konfigurasi R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
ip address 32.32.32.3 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.3 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 3.0.0.0
network 23.0.0.0
network 32.0.0.0
no auto-summary
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
Verifikasi Lab
Test ping
Sebagai referensi, berikut Konfigurasi yang lebih mudah dipahami dari Id-Networkers
Konfigurasi R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
ip address 21.21.21.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 12.12.12.2 remote-as 12
no auto-summary
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
ip address 21.21.21.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 12.12.12.2 remote-as 12
no auto-summary
!
Konfigurasi R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface Serial1/0
ip address 32.32.32.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.2 255.255.255.0
serial restart-delay 0
!
interface FastEthernet2/0
ip address 21.21.21.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
!
interface Serial1/0
ip address 32.32.32.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.2 255.255.255.0
serial restart-delay 0
!
interface FastEthernet2/0
ip address 21.21.21.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 12.12.12.1 remote-as 12
neighbor 23.23.23.3 remote-as 3
no auto-summary
!
no synchronization
bgp log-neighbor-changes
neighbor 12.12.12.1 remote-as 12
neighbor 23.23.23.3 remote-as 3
no auto-summary
!
Konfigurasi R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
ip address 32.32.32.3 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.3 255.255.255.0
serial restart-delay 0
!
router bgp 3
no synchronization
bgp log-neighbor-changes
neighbor 23.23.23.2 remote-as 12
no auto-summary
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
ip address 32.32.32.3 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.3 255.255.255.0
serial restart-delay 0
!
router bgp 3
no synchronization
bgp log-neighbor-changes
neighbor 23.23.23.2 remote-as 12
no auto-summary
!
Advertise suatu route di Router R3 ke BGP
Cek disisi Router R1
Tidak ada tanda > best pada route 33.33.33.33 yang dikarenakan next-hop nya tidak reachable. Salah satu solusinya yakni menjadikan Router R2 sebagai next-hop Router R1 untuk menuju ke Router R3
Cek lagi di sisi Router R1
Perhatikan bahwasanya ip next ho nya sudah berubah dari Router R3 menjadi Router R2.
Namun demikian tetap saja Router R1 tidak bisa ping ke R3, karena walau Router R1 punya routing tabel ke Router R3, namun tidak dengan Router R3 yang tidak memiliki route sama sekali terhadap Router R1.
Untuk itu perlu dilakukan advertise salah satu ip Router R1 ke BGP untuk dijadikan sebagai source saat ping ke Router R3.
Ping lagi dengan menggunakan source nya.
jadi Intinya prefix dari eBGP begitu masuk ke iBGP tidak akan di rubah next-hop addressnya oleh router edge eBGP,sehingga perlu di rubah ip addressnya ya
BalasHapusNext-hop-self digunakan jika ip next-hop nya unreachable. Pada contoh diatas R1 menuju R3 dengan next-hop ip nya adalah(23.23.23.3), dimana ip tersebut tidak directly connected dengan R1. Maka ada 2 alternatif agar R1 dapat terhubung denga R3, salah satunya dengan menggunakan next-hop-self.
BalasHapus