Objective :
- Mengetahui solusi untuk konfigurasi full mesh yang ada pada iBGP, yakni dengan dikonfigurasikan dalam BGP Confederation
- Dengan BGP Confederation, maka dibuat beberapa sub-AS didalam AS 12 sehingga seolah-olah seperti eBGP. Karena pada eBGP tidak memerlukan full mesh peering
Topologi Lab
- Nilai main AS nya digunakan sebagai BGP Identifiernya
- AS 12001 memiliki BGP Confederation peers ke AS 12002
- AS 12002 memiliki BGP Confederation peers ke AS 12001 dan 12003
- AS 12003 memiliki BGP Confederation peers ke AS 12002 dan eBGP 6
- Semua Router R1-R5 dianggap oleh Router R6, semuanya sebagai AS 123
Konfigurasi R1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 14.14.14.1 255.255.255.0
no fair-queue
serial restart-delay 0
clock rate 2016000
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 14.14.14.1 255.255.255.0
no fair-queue
serial restart-delay 0
clock rate 2016000
!
router bgp 12001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12002 12003
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 14.14.14.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 12002
neighbor 14.14.14.4 remote-as 12001
no auto-summary
!
router bgp 12001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12002 12003
network 1.1.1.1 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 14.14.14.0 mask 255.255.255.0
neighbor 12.12.12.2 remote-as 12002
neighbor 14.14.14.4 remote-as 12001
no auto-summary
!
Konfigurasi R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 25.25.25.2 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12001 12003
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 25.25.25.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 12001
neighbor 23.23.23.3 remote-as 12003
neighbor 25.25.25.5 remote-as 12002
no auto-summary
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 25.25.25.2 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12001 12003
network 2.2.2.2 mask 255.255.255.255
network 12.12.12.0 mask 255.255.255.0
network 23.23.23.0 mask 255.255.255.0
network 25.25.25.0 mask 255.255.255.0
neighbor 12.12.12.1 remote-as 12001
neighbor 23.23.23.3 remote-as 12003
neighbor 25.25.25.5 remote-as 12002
no auto-summary
!
Konfigurasi R3
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 36.36.36.3 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12003
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12001 12002
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 36.36.36.0 mask 255.255.255.0
neighbor 23.23.23.2 remote-as 12002
neighbor 36.36.36.6 remote-as 6
no auto-summary
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 36.36.36.3 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12003
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12001 12002
network 3.3.3.3 mask 255.255.255.255
network 23.23.23.0 mask 255.255.255.0
network 36.36.36.0 mask 255.255.255.0
neighbor 23.23.23.2 remote-as 12002
neighbor 36.36.36.6 remote-as 6
no auto-summary
!
Konfigurasi R4
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Serial1/0
ip address 14.14.14.4 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12002 12003
network 4.4.4.4 mask 255.255.255.255
network 14.14.14.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 12001
no auto-summary
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Serial1/0
ip address 14.14.14.4 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12001
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12002 12003
network 4.4.4.4 mask 255.255.255.255
network 14.14.14.0 mask 255.255.255.0
neighbor 14.14.14.1 remote-as 12001
no auto-summary
!
Konfigurasi R5
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Serial1/0
ip address 25.25.25.5 255.255.255.0
serial restart-delay 0
clock rate 2016000
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Serial1/0
ip address 25.25.25.5 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 12002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12001 12003
network 5.5.5.5 mask 255.255.255.255
network 25.25.25.0 mask 255.255.255.0
neighbor 25.25.25.2 remote-as 12002
no auto-summary
!
router bgp 12002
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 123
bgp confederation peers 12001 12003
network 5.5.5.5 mask 255.255.255.255
network 25.25.25.0 mask 255.255.255.0
neighbor 25.25.25.2 remote-as 12002
no auto-summary
!
Konfigurasi R6
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Serial1/0
ip address 36.36.36.6 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 6
no synchronization
bgp log-neighbor-changes
network 6.6.6.6 mask 255.255.255.255
network 36.36.36.0 mask 255.255.255.0
neighbor 36.36.36.3 remote-as 123
no auto-summary
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Serial1/0
ip address 36.36.36.6 255.255.255.0
serial restart-delay 0
clock rate 2016000
!
router bgp 6
no synchronization
bgp log-neighbor-changes
network 6.6.6.6 mask 255.255.255.255
network 36.36.36.0 mask 255.255.255.0
neighbor 36.36.36.3 remote-as 123
no auto-summary
!
Verifikasi Lab
Pastikan IP Loopback0 semua Router dapat diping
Tidak ada komentar:
Posting Komentar