Rabu, 25 Juli 2012

Lab 5. RIP Mindah Jalur - Offset List

Objective : Seperti yang kita ketahui protocol RIP memilih hop terpendek dalam memilih jalur terbaiknya. Namun, di inginkan hasil akhirnya dari R2 ping ke interface loopback pada R1 melalui jalur fasteth yaitu R2-R3-R1 tidak melalui jalur serial lagi atau R2-R1.

Ok langsung saja berikut topology nya :

















Konfigurasi R1 :

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.13.13.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 clock rate 2000000
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary
!

Konfigurasi R2 :

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 clock rate 2000000
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary
!

Konfigurasi R3 :

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.13.13.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

Pastikan routing tabel nya dan ip int loopback semua router bisa di ping..

















Ok seperti yang terlihat semua int loopback router bisa di ping. Sekarang coba kita trace dari R2 dengan tujuan ip int loopback R1..


Terlihat jalur nya masih memilih via 12.12.12.1 yaitu interface Serial0/0 karena link R2-R1 jumlah hopcount nya satu sedangkan link R2-R3 jumlah hopcount nya dua. RIP memilih hop terpendek dalam menentukan jalur terbaiknya. Sekarang kita akan manipulasi hopcountnya dengan perintah offset-list, seolah-olah hopcount pada interface Serial0/0 lebih besar dari hopcount interface FastEth0/0..

Ada 2 cara yang bisa dilakukan untuk memanipulasi offset-list ini. Pertama, akan kita lakukan konfigurasi di R1..






Dan sekarang mari kita lihat routing table pada R2 dan kita trace ke ip int loopback R1..















That's cool, sekarang jalur nya sudah lewat interface FastEth0/0.. Mari kita coba cara ke-2
Sebelumnya kita hapus dulu konfigurasi offset-list pada R1.











Jika kita konfigurasinya pada R1, maka gunakan 'out' karena dari R1 menuju R2 prosessnya 'keluar'.
Sedangkan jika kita konfigurasinya pada R2 maka gunakan 'in' karena dari R1 menuju R2 prosesnya 'masuk'. Sekarang mari kita verifikasi kembali pada R2...


















Yups, jalur nya via FastEth0/0 melalui link R2-R3-R1... OK finish.

Mari kita lanjutkan.....

Tidak ada komentar:

Poskan Komentar