Sabtu, 29 September 2012

Lab 49. OSPF Virtual Link


Objective : Diinginkan agar semua router dapat diping meskipun areanya berbeda antara satu dengan yang lainnya. Untuk menghubungkan area lain yang tidak terhubung secara langsung dengan area 0 (backbone) dapat juga menggunakan cara virtual link.

Topology dan konfigurasinya sebagai berikut :
Konfigurasi R1
 
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 network 12.12.12.1 0.0.0.0 area 1
 network 1.1.1.1 0.0.0.0 area 0
Konfigurasi R2
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 2.2.2.2
 network 12.12.12.2 0.0.0.0 area 1
 network 23.23.23.2 0.0.0.0 area 2
 network 2.2.2.2 0.0.0.0 area 1
Konfigurasi R3
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 3.3.3.3
 network 23.23.23.3 0.0.0.0 area 2
 network 3.3.3.3 0.0.0.0 area 3

Cek routing tabel masing-masing router
Pada OSPF, bila diinginkan menggunakan area lain selain area 0, maka area tersebut harus terhubung dengan area 0. Bila ternyata kondisinya ada area yang tidak tersambung dengan area 0, maka hasilnya akan seperti diatas dimana routing tabelnya tidaklah lengkap karena router-router tersebut tidak mau untuk saling berbagi informasi routing tabelnya.

Pada topology diatas, hanya Router R1 yang tersambung dengan area 0. Sedangkan Router R2 dan Router R3 tidak tersambung dengan area 0, jika ditampilkan ospf databasenya, maka hanya Router R1 yang menampilkan informasi tentang area 0. Sedangkan Router R2 dan R3 tidak menampilkan informasi tentang area 0.
Selanjutnya konfigurasikan virtual linknya, virtual link ini dikonfigurasikan dua sisi, pertama antara Router R2 dan Router R1 terlebih dahulu, berikutnya antara Router R3 dan Router R2.

Untuk Router R2 terdapat area 2 didalamnya yang tidak terhubung langsung dengan area 0, maka virtual link dibuat melalui area 1 sebagai jembatannya.
Dengan konfigurasi tersebut, maka di Router R1 akan muncul pesan seperti berikut :
Maka selanjutnya konfigurasikan virtual link di sisi Router R1
Cek lagi routing tabel Router R1
Terlihat network Area 2 yakni 23.23.23.0 sudah masuk ke dalam routing tabel, namun network Area 3 belum muncul.

Berikutnya konfigurasikan virtual link pada Router R3 dimana terdapat Area 3 didalamnya. Untuk terhubung ke Area 0, maka Area 2 digunakan sebagai jembatannya.
Maka pada Router R2 akan muncul pesan :
Konfigurasikan juga virtual link di sisi Router R2
 Untuk melakukan pengecekan virtual linknya gunakan perintah berikut :
Kemudian cek kembali routing tabel Router R1
Sekarang terlihat pada routing tabel Router R1 sudah mengenali semua network pada Area 1, Area 2, dan Area 3.
Cek routing tabel pada Router R2 dan Router R3
Hal yang sama juga terlihat didalam routing tabel pada Router R2 dan Router R3. Masing-masing IP Address loopback dari Router R1, Router R2, dan Router R3 dapat diping.

Tidak ada komentar:

Poskan Komentar