Kamis, 15 November 2012

Lab 100. BGP Multihoming - Single ISP


Objective : 
  • Mempelajari BGP redundancy
  • Mempelajari BGP Load Sharing
  • Mempelajari Atribut Weight, Local Preference, MED, AS-Path
Topologi Lab
BGP Multihoming terdapat dua tipe :
  1. BGP dengan dua link ke ISP yang sama (AS number ISP nya sama)
  • Main-Backup Mode
  • Load Sharing Mode
     2. BGP dengan dua link ke ISP yang berbeda (AS number ISP nya berbeda)
  • Main-Backup Mode
  • Load Sharing Mode
Berikut konfigurasinya

Konfigurasi R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 13.13.13.1 255.255.255.0
 clock rate 2000000
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 23
 neighbor 13.13.13.3 remote-as 23
 no auto-summary
!

Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 24.24.24.2 255.255.255.0
 clock rate 2000000
!
router bgp 23
 no synchronization
 bgp log-neighbor-changes
 neighbor 12.12.12.1 remote-as 1
 neighbor 23.23.23.3 remote-as 23
 neighbor 24.24.24.4 remote-as 4
 no auto-summary
!

Konfigurasi R3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 13.13.13.3 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 34.34.34.3 255.255.255.0
 clock rate 2000000
!
router bgp 23
 no synchronization
 bgp log-neighbor-changes
 neighbor 13.13.13.1 remote-as 1
 neighbor 23.23.23.2 remote-as 23
 neighbor 34.34.34.4 remote-as 4
 no auto-summary
!

Konfigurasi R4

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0
 ip address 24.24.24.4 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 34.34.34.4 255.255.255.0
 clock rate 2000000
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 neighbor 24.24.24.2 remote-as 23
 neighbor 34.34.34.3 remote-as 23
 no auto-summary
!

Verifikasi Lab

Periksa di sisi Router R1 
Kesimpulannya walau sudah menggunakan 2 link, namun tetap saja hanya 1 link yang digunakan. BGP defaultnya hanya menggunakan 1 link saja.

Sekarang kita akan shutdown port int s0/0 (12.12.12.1/24) sehingga paket tidak lagi melalui Router R2. Hal tersebut untuk memastikan bahwa kedua linknya berfungsi dengan baik, sehingga jangan sampai ketika main link nya berfungsi kemudian down dan berpindah ke backupnya, malah backupnya tidak berfungsi (bisa repot urusannya...hehehe). Karena hal tersebut sepertinya banyak terjadi dilapangan, sudah redundancy namun tidak berjalan dengan baik ketika failover terjadi.
Oke sekarang, link nya berpindah melalui Router R3

kemudian test kembali dengan enable kn kembali port yang menuju Router R2. Harapannya kalau link main nya UP kembali, maka link kembali ke main link nya.
Menarik, ternyata tidak mau otomatis pindah ke main link nya lagi (Router R2).

Untuk memastikan agar link ke Router R2 menjadi Main link, BGP default tidak bisa melakukannya, maka konfigurasikan attribute weight atau bisa juga local preference.
Sealin weight, kita juga bisa menggunakan Local Preference. Perbedaannya kalau pada weight pengaruhnya hanya pada router yang dikonfigurasikan weight, sedangkan kalau menggunakan local preference pengaruhnya ke semua router dalam internal BGP.

Berikut pemilihan route BGP berdasarkan atribut nya, mulai dari atas dulu, kalau nilai atributnya sama, kemudian menurun ke atribut bawahnya.
  • Weight, yang lebih tinggi yang dipilih (Cisco Proprietary)
  • Local Preference, yang lebih tinggi yang dipilih
  • Locally Originated, route berasal dari internal BGP
  • AS-Path, jalur AS terpendek yang dipilih
  • Origin (IGP, EGP, ?) route yang berasal dari eBGP dan iBGP lebih dipilih daripada route yang berasal dari EGP ataupun IGP yang diredistribute ke BGP
  • MED, nilai metric yang paling rendah yang dipilih

Cek kembali setelah dikonfigurasikan weight
Terlihat linknya melalui Router R2 kembali. Kemudian test lagi shutdown interface ke Router R2
Ketika Main link nya mati, kemudian failover menggunakan backup linknya (Router R3)

Sekarang aktifkan kembali interface menuju Router R2
Sekarang jalurnya kembali menggunakan main link nya yakni melalui Router R2.

Selain untuk mengatur trafik keluar, bisa juga untuk mengatur trafik yang masuk. Konfigurasikan di Router R1, agar trafik menuju ke network internal melalui Router R3 yang diset nilai metricnya lebih rendah (100) dibanding Router R2 (110).
Sebelum di verifikasi perlu ditambahkan next-hop-self di R3
Verifikasi dari Router R3 dan R2 menuju ke Router R1 (1.1.1.1)
Bahkan dari Router R2 untuk menuju ke Router R1 harus melalui Router R3 terlebih dahulu.

Selain menggunakan attribute MED, bisa juga menggunakan attribute AS-Path.

Hapus dulu konfigurasi MED sebelumnya. Kemudian konfigurasikan AS-Path, yakni dengan mengulang-ulang nilai AS 1 agar seolah-olah jalurnya lebih panjang sehingga tidak akan dipilih.
 Verifikasi bgp routenya.

Tidak ada komentar:

Poskan Komentar