Minggu, 11 November 2012

Lab 90. BGP Route Reflector

Objective : 
  • Mengetahui issue yang ada pada internal BGP
  • Mengetahui solusi untuk issue tersebut (Full Mesh Peers, Route Reflector, Confederation)
  • Mempelajari konfigurasi BGP Route Reflector
Topologi Lab
Pada iBGP, peers nya harus full mesh, artinya :
  • Router R1 neighbor peers ke Router R2, Router R3, Router R4
  • Router R2 neighbor peers ke Router R1, Router R3, Router R4
  • Router R3 neighbor peers ke Router R1, Router R2, Router R4
  • Router R4 neighbor peers ke Router R1, Router R2, Router R3
Permasalahannya adalah apabila ada router baru, maka selain router tersebut, peers ke Router R1, Router R2, Router R3, Router R4 juga Router lain satu persatu harus dibikin peer ke  Router tersebut, sehingga menjadi merepotkan admin tentunya.

Salah satu solusinya adalah dengan menjadikan salah satu Routernya menjadi route reflector. Pada lab kali ini Router R4 akan dijadikan sebagai route reflector server. Maka RR akan melakukan peers ke semua Router, dan semua router peer nya cukup ke RR saja

Konfigurasi R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/0
 ip address 21.21.21.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
 !
interface Serial2/0
 ip address 41.41.41.1 255.255.255.0
 serial restart-delay 0
!
router rip
 version 2
 network 1.0.0.0
 network 12.0.0.0
 network 21.0.0.0
 network 41.0.0.0
 no auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 4.4.4.4 remote-as 12
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
!

Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
 !
interface Serial1/0
 ip address 32.32.32.2 255.255.255.0
 serial restart-delay 0
 !
interface Serial1/1
 ip address 23.23.23.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet2/0
 ip address 21.21.21.2 255.255.255.0
 duplex auto
 speed auto
 !
interface FastEthernet2/1
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
 !
router rip
 version 2
 network 2.0.0.0
 network 12.0.0.0
 network 21.0.0.0
 network 23.0.0.0
 network 32.0.0.0
 no auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 ebgp-multihop 255
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 12
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
!

Konfigurasi R3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 !
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
 ip address 32.32.32.3 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 ip address 23.23.23.3 255.255.255.0
 serial restart-delay 0
 !
router rip
 version 2
 network 3.0.0.0
 network 23.0.0.0
 network 32.0.0.0
 no auto-summary
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
 
Konfigurasi R4

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 44.44.44.44 255.255.255.255
!
interface Serial1/0
 ip address 41.41.41.4 255.255.255.0
 serial restart-delay 0
!
router rip
 version 2
 network 4.0.0.0
 network 41.0.0.0
 no auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 route-reflector-client
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 route-reflector-client
 no auto-summary
!

Untuk pengetesan, advertise IP address Lo1.
 
Verifikasi Lab

Cek di setiap router dan pastikan bisa di ping dari semua router.

Tidak ada komentar:

Poskan Komentar