Minggu, 11 November 2012

Lab 73. Mutual Redistribution - Route Tagging

Objective : Mempelajari bagaimana cara untuk mencegah terjadi routing loop, yakni dengan menerapkan tagging terhadap suatu route ketika diredistribusikan.

Topologi Lab
Konfigurasi R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 13.13.13.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0
 network 13.13.13.1 0.0.0.0
 no auto-summary
!

Konfigurasi R2

!
interface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 24.24.24.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 12.12.12.2 0.0.0.0
 network 24.24.24.2 0.0.0.0
 no auto-summary
!

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.13.13.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 35.35.35.3 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 13.13.13.3 0.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 network 35.35.35.3 0.0.0.0 area 0
!

Konfigurasi R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 24.24.24.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 46.46.46.4 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 24.24.24.4 0.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 46.46.46.4 0.0.0.0 area 0
!

Konfigurasi R5

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 35.35.35.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 56.56.56.5 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 35.35.35.5 0.0.0.0 area 0
 network 56.56.56.5 0.0.0.0 area 0
!

Konfigurasi R6

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 46.46.46.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 56.56.56.6 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 46.46.46.6 0.0.0.0 area 0
 network 56.56.56.6 0.0.0.0 area 0
!

Untuk menghindari routing loop, selain dengan merubah nilai administrative distance, kita bisa juga dengan menandai atau route tagging pada setiap network yang diredistribute.

Konfigurasikan pada setiap titik redistribusi

R3(config)#router eigrp 1
R3(config-router)#redistribute ospf 1 metric 1 1 1 1 1 route-map OSPF-ke-EIGRP
R3(config-router)#router ospf 1
R3(config-router)#redistribute eigrp 1 metric 1 subnets route-map EIGRP-ke-OSPF
R3(config-router)#route-map EIGRP-ke-OSPF deny 10
R3(config-route-map)# match tag 110
R3(config-route-map)#route-map EIGRP-ke-OSPF permit 20
R3(config-route-map)#set tag 90
R3(config-route-map)#route-map OSPF-ke-EIGRP deny 10
R3(config-route-map)#match tag 90
R3(config-route-map)#route-map OSPF-ke-EIGRP permit 20
R3(config-route-map)#set tag 110
Pada Router R3 terdapat 2 redistribution :
  1. EIGRP yang diredistribute ke OSPF
  • Route dengan tag 110 akan di deny (agar route dari OSPF tidak diredistribute ke OSPF kembali)
  • Router dari EIGRP yang diredistribute ke OSPF diset dengan tag 90
     2.  OSPF yang diredistribute ke EIGRP
  •  Route dengan tag 90 akan di deny (agar route dari EIGRP tidak diredistribute ke EIGRP kembali)
  •  Route dari OSPF yang diredistribute ke EIGRP diset dengan tag 110
Hal yang sama diatas juga dikonfigurasikan di Router R4

R4(config)#router eigrp 1
R4(config-router)#redistribute ospf 1 metric 1 1 1 1 1 route-map OSPF-ke-EIGRP
R4(config-router)#router ospf 1
R4(config-router)#redistribute eigrp 1 metric 1 subnets route-map EIGRP-ke-OSPF
R4(config-router)#route-map EIGRP-ke-OSPF deny 10
R4(config-route-map)# match tag 110
R4(config-route-map)#route-map EIGRP-ke-OSPF permit 20
R4(config-route-map)#set tag 90
R4(config-route-map)#route-map OSPF-ke-EIGRP deny 10
R4(config-route-map)#match tag 90
R4(config-route-map)#route-map OSPF-ke-EIGRP permit 20
R4(config-route-map)#set tag 110

Verifikasi Lab
 
Cek routing tabel di Router R1
Tag tersebut menandakan bahwa network tersebut berasal dari area EIGRP. Pada Router R3 yang menjadi titik redistribusi, network tersebut tidak akan diredistribute kembali ke dalam area EIGRP dimana network tersebut berasal. Network tersebut sudah ditandai dan berdasarkan penanda tersebut, diberlakukan aturan untuk tidak diredistribute kembali sehingga tidak terjadi routing loop. Demikian juga halnya dari sisi router area OSPF (Router R5 dan Router R6).

Lakukan test ping dan traceroute

Cek routing tabel di R6

Lakukan test ping dan traceroute

Tidak ada komentar:

Poskan Komentar