Kamis, 15 November 2012

Lab 102. BGP Multihoming 2 ISP Berbeda


Objective :
  • Mempelajari konfigurasi BGP Load Balancing bila menggunakan ISP berbeda
  • Mempelajari agar pembagian trafik load sharing berjalan dengan semestinya sesuai bandwidth yang dimiliki masing-masing link
Topologi Lab :
 Konfigurasi R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 13.13.13.1 255.255.255.0
 clock rate 2000000
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 2
 neighbor 13.13.13.3 remote-as 3
 no auto-summary
!

Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 24.24.24.2 255.255.255.0
 clock rate 2000000
!
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 neighbor 12.12.12.1 remote-as 1
 neighbor 24.24.24.4 remote-as 4
 no auto-summary
!

Konfigurasi R3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 13.13.13.3 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 34.34.34.3 255.255.255.0
 clock rate 2000000
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 neighbor 13.13.13.1 remote-as 1
 neighbor 34.34.34.4 remote-as 4
 no auto-summary
!

Konfigurasi R4

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0
 ip address 24.24.24.4 255.255.255.0
 clock rate 2000000
!
interface Serial0/1
 ip address 34.34.34.4 255.255.255.0
 clock rate 2000000
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 neighbor 24.24.24.2 remote-as 2
 neighbor 34.34.34.3 remote-as 3
 no auto-summary
!

Verifikasi Lab

Hasilnya pada BGP route di Router R1, muncul 2 jalur next hop menuju ke 4.4.4.4, namun tidak load sharing meskipun sudah dikonfigurasikan maximum-paths 2, hanya berfungsi sebagai backup link saja.

Agar dapat load sharing melalui 2 ISP berbeda gunakan perintah berikut :
Oke sekarang sudah load sharing. Permasalahan berikutnya adalah seandainya bandwidth antara kedua link tersebut berbeda, maka bagaimana proses sharing antar kedua link tersebut.
Cek lagi disisi R1
Ternyata masih 1:1 padahal bandwidth nya berbeda, tentunya hal tersebut akan memunculkan permasalahan, terutama bila link satu dengan link lain bandwidth nya terpaut jauh.

Untuk itu perlu ditambahkan konfigurasi berikut
Seperti yang terlihat, sekarang load sharingnya sudah dalam perbandingan yang baik, sehingga kedua link tersebut bisa digunakan sesuai kemampuannya. Serial0/1 lebih sering digunakan untuk mengirimkan trafik dikarenakan bandwidtnya lebih besar dibandingkan dengan bandwidth Serial0/0

Tidak ada komentar:

Poskan Komentar