Minggu, 11 November 2012

Lab 87. eBGP Peering

Objective : Mempelajari bagaimana mengkonfigurasikan Peers BGP External antara Router R2 (AS12) dan Router R3 (AS3)

Topologi Lab
Konfigurasi R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
interface Loopback11
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet1/1
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
 !
interface FastEthernet1/0
 ip address 21.21.21.1 255.255.255.0
 duplex auto
 speed auto
 !
router rip
 version 2
 network 1.0.0.0
 network 12.0.0.0
 network 21.0.0.0
!
router bgp 12
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 update-source loopback0
 network 11.11.11.11 mask 255.255.255.255
!

Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet2/1
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
 !
interface FastEthernet2/0
 ip address 21.21.21.2 255.255.255.0
 duplex auto
 speed auto
 !
interface Serial1/0
 ip address 23.23.23.2 255.255.255.0
!
router rip
 version 2
 network 2.0.0.0
 network 12.0.0.0
 network 21.0.0.0
 no auto-summary
!
router bgp 12
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source loopback 0
 network 22.22.22.22 mask 255.255.255.255
!

Konfigurasi R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 !
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
 ip address 23.23.23.3 255.255.255.0
 ! 

Berikutnya konfigurasi BGP

Verifikasi Lab

Cek BGP Peers nya

Advertise ke dalam BGP IP Loopback nya
Periksa kembali BGP Peers nya
Terlihat sekarang sudah ada 2 route yakni 2.2.2.2/32 dan 22.22.22.22/32

Pastikan network 2.2.2.2/32 dan 22.22.22.22/32 terdapat didalam routing tabelnya.
Test ping

Perhatian : Di dalam video untuk R1 tidak dikonfigurasikan

Ok. sekarang verifikasi dilakukan di Router R3 dan Router R1
 Terlihat request timed out, cek di sisi Router R1
Terlihat bahwasanya route BGP dari Router R3 (33.33.33.33) tidak ada tanda > best nya. hal tersebut dikarenakan IP Next Hop nya tidak reachable dari Router R1. Yang menyebabkan ketika paket ping dikirim dan sampai ke Router R1, Router R1 tidak tau untuk mengembalikan paket icmp tersebut ke Router R3.

Cek routing tabel Router R1
Terlihat tidak satupun route yang berasal dari Router R3 baik itu interface loopback maupun physicalnya. Terutama IP 23.23.23.3 yang menjadi next hop menuju ke 33.33.33.33
Ada beberapa cara yang bisa dilakukan, salah satunya adalah mengadvertise network 23.23.23.0 ke BGP pada Router R2.
Cek lagi di Router R1
Terlihat muncul route 23.23.23.0 serta pada route 3.3.3.3 sudah muncul tanda > best yang dikarenakan next hopnya sudah reachable.

Selanjutnya lakukan test ping kembali dari Router R3
Hasilnya reply. Sekarang bagaimana jika diping dari Router R1
Eits request time out. Sekarang gunakan source yang ip nya sudah diketahui Router R3. Cek dulu IP nya yang dikenali apa saja di Router R3.
Ternyata hanya IP 11.11.11.11 saja, maka gunakan sebagai source nya.
Yups reply, pada ping sebelumnya RTO karena, ketika tidak menambahkan source nya, maka yang digunakan sebagai source adalah ip physicalnya yakni 12.12.12.1 yang mana tidak ada dalam routing tabelnya Router R3.
Jika diinginkan tanpa menggunakan source. Cara yang sama bisa dilakukan yakni mengadvertise network 12.12.12.0 ke BGP pada Router R1 sehingga dapat dikenali oleh Router R3
Lakukan test ping lagi dari Router R1 tanpa menggunakan source
Hasilnya langsung reply.

Tidak ada komentar:

Poskan Komentar