Minggu, 11 November 2012

Lab 88. eBGP Loopback - Multihop

Objective : Mempelajari bagaimana mengkonfigurasikan Peers BGP External antar Router R2 (AS12) dan Router R3 (AS3) menggunakan interface loopbacknya

Topologi Lab
Selain menggunakan interface physical sebagai neighbor peers eBGP, bisa juga menggunakan ip loopbacknya. Namun demikian ini sifatnya hanya di labg saja, tidak digunakan untuk real di lapangan.
Perlu untuk diketahui bahwasanya menggunakan dynamic routing pada eBGP adalah suatu hal yang tidak mungkin dilakukan di kenyataan dilapangan terkait dengan policy di setiap company. Namun kali ini sifatnya hanya pembelajarang di lab saja.

Agar loopbacknya bisa di ping, gunakan IGP (RIP,OSPF,EIGRP) atau static route

Konfigurasi R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
 !
interface FastEthernet1/0
 ip address 21.21.21.1 255.255.255.0
 duplex auto
 speed auto
 !
interface FastEthernet1/1
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 1.0.0.0
 network 12.0.0.0
 network 21.0.0.0
 no auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!

Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
!
interface Serial1/0
 ip address 32.32.32.2 255.255.255.0
 serial restart-delay 0
 !
interface Serial1/1
 ip address 23.23.23.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet2/0
 ip address 21.21.21.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/1
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
 !
router rip
 version 2
 network 2.0.0.0
 network 12.0.0.0
 network 21.0.0.0
 network 23.0.0.0
 network 32.0.0.0
 no auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
!

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 !
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
 !
interface Serial1/0
 ip address 32.32.32.3 255.255.255.0
 serial restart-delay 0
 !
interface Serial1/1
 ip address 23.23.23.3 255.255.255.0
 serial restart-delay 0
 !
router rip
 version 2
 network 23.0.0.0
 network 32.0.0.0
 no auto-summary
!

Perhatian : Routing static yang ada di video diganti dengan routing RIP.

Konfigurasikan BGP
Selain menambahkan update source, kita juga harus menambahkan keyword ebgp-multihop. Hal tersebut mengingat pada ebgp syaratnya musti directly connected sedangkan pada penggunaan loopback tidak lagi directly connected interfacenya.

Advertise IP Loopback nya

Verifikasi Lab

Periksa show ip bgp
Test ping

Tidak ada komentar:

Poskan Komentar