Jumat, 16 November 2012

Lab 104. MPLS VPN


Objective Lab : 
  • Mempelajari konfigurasi membuat Jaringan MPLS VPN

Topologi Lab
Konfigurasi PE1 Router

 !
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.1 255.255.255.0
 description ###Link to P Router###
 duplex auto
 speed auto
 mpls ip
 !
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 65000
 neighbor 3.3.3.3 update-source Loopback0
 no auto-summary
 !

Konfigurasi P Router

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
interface FastEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 description ###Link to PE1 Router###
 duplex auto
 speed auto
 mpls ip
 !
interface FastEthernet1/1
 ip address 23.23.23.2 255.255.255.0
 description ###Link to PE2 Router###
 duplex auto
 speed auto
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!

Konfigurasi PE2 Router

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 ip address 23.23.23.3 255.255.255.0
 description ###Link to P Router###
 duplex auto
 speed auto
 mpls ip
 !
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 65000
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
 !

Verifikasi di sisi MPLS Backbone

Adapun tahapan konfigurasi membuat MPLS VPN adalah sebagai berikut :
         1. Membuat VRF
  • VRF (Virtual Router Forwarding)  diperlukan untuk setiap customer, misalnya terdapat 2 customer maka kita juga mengkonfigurasikan 2 VRF.
  • Virtual Router ini seolah-olah seperti masing-masing customer memiliki router sendiri yang mengatur trafik mereka melalui MPLS domain.
  • Masing-masing VRF memiliki identitas sendiri-sendiri untuk setiap customer
  • Karena VRF inilah, dimungkinkan customer berbeda namun memiliki IP Address yang sama dapat diakomodir menggunakan MPLS network
Berikut adalah langkah konfigurasinya

Router PE1
Pada PE1 terdapat 2 customer yakni BRI dan BCA, maka dibuat 2 VRF yang bernama vrf bri.kiri dan vrf bca.kiri. VRF memiliki 2 komponen utama yaitu :
  1. RD (Route Distinguisher)
  • RD merupakan identitas dari sebuah VRF
  • Setiap customer memiliki VRF sendiri
  • Penulisan RD dapat dituliskan seperti format berikut
    • 16-bit AS Number : 32-bit number --> contoh : 65000 : 1
    • 32-bit IP Address  : 15-bit number --> contoh : 192.168.0.1 : 1
  • RT (Route Target)
    • RT digunakan untuk menentukan route yang mana yang akan di import ke dalam VRF dan menentukan route yang mana yang akan di export
    • Sifatnya seperti routing policy
    • Format penulisannya seperti RD yakni seperti berikut
      • 16-bit AS Number : 32-bit number --> contoh : 65000 : 1
      • 32-bit IP Address  : 15-bit number --> contoh : 192.168.0.1 : 1
Router PE2
Pada PE2 konfigurasi VRF nya sama persis dengan PE1

   2. Konfigurasi IP Address & VRF pada PE yang menuju CE

 Setelah VRF dikonfigurasikan, maka kita bisa mengkonfigurasikan IP Address yang sama pada beberapa interface router. Tanpa VRF, pada router tidak bisa dikonfigurasikan IP Address yang sama kecuali di bridging.

Router PE1
 Router PE2

Verifikasi

    3. Mengaktifkan MP-BGP

MP-BGP (Multi Protocol BGP) digunakan untuk membawa informasi routing, IPv4 prefixes, VPN Customer dan lain-lain menuju Router PE lainnya.

 Selanjutnya gunakan routing protokol. Routing protokol yang digunakan pada koneksi router PE dan CE ada beberapa pilihan antara lain :
  1. Static
  2. RIPv2
  3. EIGRP
  4. OSPF
  5. BGP

Tidak ada komentar:

Poskan Komentar