Minggu, 18 November 2012

Lab 108. MPLS VPN - PE CE BGP Routing

Objective : Mempelajari konfigurasi membuat Jaringan MPLS VPN dengan menggunakan Routing Protocol BGP pada koneksi Router PE dan CE

Topologi Lab
Konfigurasi PE1
!
ip vrf bca.kiri
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2
!
ip vrf bri.kiri
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 description ###Link to P Router###
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/1
 description ###Link to BCA###
 ip vrf forwarding bca.kiri
 ip address 10.10.10.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description ###Link to BRI###
 ip vrf forwarding bri.kiri
 ip address 10.10.10.1 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 65000
 neighbor 3.3.3.3 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
!
Konfigurasi P Router 
 !
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
 description ###Link to PE1 Router###
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/1
 description ###Link to PE2 Router###
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!
Konfigurasi PE2
!
ip vrf bca.kanan
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2
!
ip vrf bri.kanan
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 description ###Link to P Router###
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
 mpls ip
 !
interface FastEthernet1/1
 description ###Link to BRI###
 ip vrf forwarding bri.kanan
 ip address 10.10.10.5 255.255.255.252
 duplex auto
 speed auto
 !
interface FastEthernet2/0
 description ###Link to BCA###
 ip vrf forwarding bca.kanan
 ip address 10.10.10.5 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 65000
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
!

Konfigurasi CE1_BCA

!
interface Loopback0
 ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet1/0
 description ###Link to MPLS###
 ip address 10.10.10.2 255.255.255.252
 duplex auto
 speed auto
 !
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 10.10.10.1 remote-as 65000
 no auto-summary
!
 
 Konfigurasi CE2_BCA

!
interface Loopback0
 ip address 44.44.44.44 255.255.255.255
 !
interface FastEthernet1/0
 description ###Link to MPLS ###
 ip address 10.10.10.6 255.255.255.252
 duplex auto
 speed auto
 !
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 10.10.10.5 remote-as 65000
 no auto-summary
!
Konfigurasi PE - CE dengan BGP Routing (CE1_BCA dan CE2_BCA)
Verifikasi Lab
Periksa routing tabelnya, ping dan lakukan traceroute

Tidak ada komentar:

Posting Komentar