Minggu, 11 November 2012

Lab 92. BGP Attribute (Origin)

Objective :
  • Tiap routing protokol memiliki nilai metric, rip metric nya adalah hop count, ospf adalah cost, eigrp adalah bandwidth dan delay.
  • BGP memiliki nilai metric yang banyak biasa disebut BGP atribut
  • Origin adalah salah satu BGP attribute yang akan dilabkan kali ini
Topologi Lab
Konfigurasi R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
 !
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 200
 no auto-summary
!








Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 23.23.23.2 255.255.255.0
 serial restart-delay 0
 clock rate 2016000
 !
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.2 mask 255.255.255.255
 redistribute static
 neighbor 12.12.12.1 remote-as 100
 neighbor 23.23.23.3 remote-as 200
 no auto-summary
!
ip route 50.50.50.50 255.255.255.255 23.23.23.3
!

Konfigurasi R3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback50
 ip address 50.50.50.50 255.255.255.255
!
interface Loopback60
 ip address 60.60.60.60 255.255.255.255
!
interface Serial1/0
 ip address 23.23.23.3 255.255.255.0
 serial restart-delay 0
 clock rate 2016000
 !
router rip
 version 2
 network 60.0.0.0
 no auto-summary
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 redistribute rip
 neighbor 23.23.23.2 remote-as 200
 no auto-summary
!

Verifikasi Lab

Periksa show ip bgp di Router R1
i = route yg berasal dari BGP (eBGP/iBGP) yang diadvertise melalui perintah network x.x.x.x mask y.y.y.y
e = route yang berasal dari protocol EGP (Saat ini sudah tidak ada protocol tersebut)
? = route yang berasal dari protocol lain (Static/RIP/OSPF/EIGRP) yang diredistribute kedalam BGP

Router R1 untuk menuju network 2.2.2.2 dan 3.3.3.3 adalah via "200 i" yang artinya Next AS Path nya adalah AS 200 dan nilai origin dari routernya adalah i

Router R1 untuk menuju network 50.50.50.50 dan 60.60.60.60 adalah via "200 ?" yang artinya Next AS Path nya adalah AS 200 dan nilai origin dari routernya adalah ?

 Gambar diatas menunjukkan semua atribut yang digunakan oleh BGP

Secara umum atribut BGP terbagi menjadi dua, yakni :
1. Well Known
  • Semua pabrikan perangkat merk apapun yang menjalankan BGP pasti mengenali dan memiliki atribut tipe ini
  • Well known atribut terbagi menjadi dua, yakni : 
    1a. Mandatory
  • Attribut ini pasti ada setiap kali router menjalankan BGP
  • Terbagi menjadi 3 yakni
  1. AS-Path : menampilkan informasi jalur AS suatu route
  2. Next-hop : menampilkan ip via untuk menuju ke suatu route
  3. Origin : menampilkan informasi dari mana route berasal, apakah dari BGp atau IGP yang diredistribute ke BGP
     1b. Optional
  • Atribut ini baru ada apabila dikonfigurasikan, bila tidak dikonfigurasikan, maka atribut ini tidak dibawa serta oleh BGP 
  • Terbagi menjadi 2 yakni
  1. Local Preference: digunakan untuk menentukan jalur upstream
  2. Automic Aggregate : merupakan suatu route hasil summarization
 2. Optional
  • Attribut ini hanya dimiliki oleh beberapa pabrikan tertentu saja, tidak semua perangkat yang menjalankan BGP mengenali dan memiliki fitur ini
  • Optional atribut terbagi menjadi dua, yakni
      2a. Transitive 
  • Attribut ini apabila tidak dikenali oleh perangkat tertentu, maka atribut ini akan tetap diteruskan ke yang lainnya.
  • Terbagi menjadi dua, yakni :
  1. Aggregator : merupakan router yang melakukan summarization
  2. Community, terbagi menjadi 4 :
  • No-export : attribut ini akan menjadikan suatu route diadvertise hanya ke internal bgp saja
  • No-advertise : atribut ini akan menjadikan suatu route tidak diadvertise kemana-mana, baik internal maupun external
  • Internet : atribut ini akan menjadikan route nya diadvertise kemana saja
  • Local-as : atribut ini hanya ada pada bgp confederation, dimana route nya hanya akan diadvertise kedalam sub-as yang sama saja, tidak diadvertise ke sub AS yang lain.
     2b. Non Transitive
  • Atribut ini apabila tidak dikenali oleh perangkat tertentu, maka akan didrop atributnya oleh perangkat tersebut
  • Terbagi menjadi tiga yakni 
  1. MED : digunakan untuk menentukan trafik kembali/downstream
  2. Originator : menunjukkan router yang menjadi route reflector
  3. Cluster ID, menunjukkan nilai cluster id yang digunakan pada redundant route reflector

Tidak ada komentar:

Poskan Komentar