Kamis, 15 November 2012

Lab 99. BGP Attribute (Aggregator & Automic Aggregate)


Objective : 
  • Attribute ini akan ada bila dikonfigurasikan summarization, maka lab kali ini akan belajar mensummarikan suatu route pada BGP
Topologi Lab
Konfigurasi R1

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback11
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0
 no auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor IBGP peer-group
 neighbor IBGP remote-as 123
 neighbor IBGP update-source Loopback0
 neighbor 2.2.2.2 peer-group IBGP
 neighbor 3.3.3.3 peer-group IBGP
 no auto-summary
!

Konfigurasi R2

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback22
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 24.24.24.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 12.12.12.2 0.0.0.0
 network 23.23.23.2 0.0.0.0
 no auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor IBGP peer-group
 neighbor IBGP remote-as 123
 neighbor IBGP update-source Loopback0
 neighbor IBGP next-hop-self
 neighbor 1.1.1.1 peer-group IBGP
 neighbor 3.3.3.3 peer-group IBGP
 neighbor 24.24.24.4 remote-as 4
 no auto-summary
!

Konfigurasi R3

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 23.23.23.3 0.0.0.0
 no auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor IBGP peer-group
 neighbor IBGP remote-as 123
 neighbor IBGP update-source Loopback0
 neighbor 1.1.1.1 peer-group IBGP
 neighbor 2.2.2.2 peer-group IBGP
 no auto-summary
!

Konfigurasi R4

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 44.44.44.44 255.255.255.255
!
interface Serial0/0
 ip address 24.24.24.4 255.255.255.0
 clock rate 2000000
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 24.24.24.2 remote-as 123
 no auto-summary
!

Tambahkan beberapa ip loopback di Router R4 yang nantinya akan di aggregate
Advertise ke BGP
Cek BGP Route di Router R1, dimana muncul banyak route network 40.x.x.x

Lakukan Aggregate di Router R4
Cek kembali BGP route di Router R1, pastikan muncul route summarization nya
Pada BGP route yang disummarisasi, route aslinya tetap tidak mau hilang, hanya nambah 1 route hasil summarisasi saja.
Lakukan aggregate single route di Router R4, agar hanya muncul 1 route summarisasi saja
Cek kembali BGP route di Router R1
Sudah muncul hanya 1 route summarisasi saja

Berikutnya bila yang ingin di summarisasikan hanya beberapa route saja, tidak semua yang dalam satu blok subnet, maka konfigurasikan Aggregate Suppress Map berikut :
Muncul S (suppress map) pada BGP route nya
Cek kembali BGP route di R1, summarisasi yang di suppress map akan di blok.

Tidak ada komentar:

Posting Komentar