Minggu, 11 November 2012

Lab 72. Mutual Redistribution - 2 Titik

Objective : 
  • Mempelajari akibat dari melakukan mutual redistribution pada 2 titik redistribution yang berbeda, yakni terjadinya routing loop
  • Mempelajari bagaimana cara untuk mencegah terjadi routing loop, yakni dengan merubah nilai AD nya
Topologi Lab
Konfigurasi R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
interface Serial1/0
 ip address 12.12.12.1 255.255.255.0
 serial restart-delay 0
 !
interface Serial1/1
 ip address 13.13.13.1 255.255.255.0
 serial restart-delay 0
 !
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
 network 13.13.13.1 0.0.0.0 area 0
!

Konfigurasi R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial1/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!
interface FastEthernet2/0
 ip address 10.10.10.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 2.2.2.2 0.0.0.0 area 0
 network 12.12.12.2 0.0.0.0 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 1
 network 10.0.0.0
 distance 109 10.10.10.4 0.0.0.0
 no auto-summary
!

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial1/0
 ip address 13.13.13.3 255.255.255.0
 serial restart-dely 0
!
interface FastEthernet2/0
 ip address 10.10.10.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 3.3.3.3 0.0.0.0 area 0
 network 13.13.13.3 0.0.0.0 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 1
 network 10.0.0.0
 no auto-summary
!

Konfigurasi R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet1/0
 ip address 10.10.10.4 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 4.0.0.0
 network 10.0.0.0
 no auto-summary
!

Verifikasi Lab

Cek routing tabel

Satu titik redistribusi tidak memiliki resiko apapun, namun dua titik redistribusi akan rentan terjadi adanya routing loop.

Untuk pengetesan, shutdown interface loopback0 pada Router R4 terlebih dahulu. Kemudian kalau dicek ternyata masih terdapat dalam routing tabel masing-masing router meski sudah di shutdown.

Jalankan traceroute menuju IP tersebut yakni 4.4.4.4
Terlihat ngeloop terus

Bahkan setelah diaktifkan kembali interface lo0 Router R4 masih tetap gak bisa diakses ip lo0 Router R4 tersebut (4.4.4.4.4).
Routing loop terjadi karena pada satu titik redistribusi (Router R3) lebih memilih menginstal RIP untuk network 4.4.4.4 sedangkan titik redistribusi lain (Router R2) lebih memilih mengistal OSPF E2 dalam routing tabelnya.

Dan tentunya router akan memilih yang nilai AD nya paling rendah, sehingga akibatnya paket tidak akan memilih ke area RIP (120), melainkan kembali lagi ke area OSPF (110), demikian seterusnya sehingga paket ngeloop dan tidak pernah sampai ke network yang dituju (4.4.4.4)

Maka solusinya harus dibuat agar kedua titik redistribusi untuk lebih memilih RIP dibandingkan OSPF, yakni dengan membuat nilai AD RIP yang diredistribute dari Router R4 lebih kecil dibanding OSPF (110).
Cek lagi routing tabelnya

Ok sekarang di setiap titik redistribusi sudah kompakan bahwa network 4.4.4.4 akan dilewatkan ke area RIP.

Coba test lagi dari Router R1. 
Mantap, sudah gak ngeloop lagi..

Tidak ada komentar:

Poskan Komentar